ZPOOL(8) | System Manager's Manual | ZPOOL(8) |
zpool
— configure
ZFS storage pools
zpool |
-?V |
zpool |
version |
zpool |
subcommand
[arguments] |
The zpool
command configures ZFS storage
pools. A storage pool is a collection of devices that provides physical
storage and data replication for ZFS datasets. All datasets within a storage
pool share the same space. See zfs(8) for
information on managing datasets.
For an overview of creating and managing ZFS storage pools see the zpoolconcepts(7) manual page.
All subcommands that modify state are logged persistently to the pool in their original form.
The zpool
command provides subcommands to
create and destroy storage pools, add capacity to storage pools, and provide
information about the storage pools. The following subcommands are
supported:
zpool
-?
zpool
-V
,
--version
zpool
version
zpool
userland utility and the ZFS kernel module.attach
), or performs
the inverse operation (detach
).Available pool properties listed in the zpoolprops(7) manual page.
zpool
import
--rewind-to-checkpoint
.zpool
sync
will sync all
pools on the system. Otherwise, it will sync only the specified
pool(s).The following exit values are returned:
The following command creates a pool with a single raidz root vdev that consists of six disks:
# zpool
create
tank
raidz
sda sdb sdc sdd sde sdf
The following command creates a pool with two mirrors, where each mirror contains two disks:
# zpool
create
tank
mirror sda sdb
mirror sdc sdd
The following command creates a non-redundant pool using two disk partitions:
# zpool
create
tank
sda1 sdb2
The following command creates a non-redundant pool using files. While not recommended, a pool based on files can be useful for experimental purposes.
# zpool
create
tank
/path/to/file/a /path/to/file/b
The following command converts an existing single device sda into a mirror by attaching a second device to it, sdb.
# zpool
attach
tank sda
sdb
The following command adds two mirrored disks to the pool tank, assuming the pool is already made up of two-way mirrors. The additional space is immediately available to any datasets within the pool.
# zpool
add
tank
mirror sda sdb
The following command lists all available pools on the system. In this case, the pool zion is faulted due to a missing device. The results from this command are similar to the following:
#zpool
list
NAME SIZE ALLOC FREE EXPANDSZ FRAG CAP DEDUP HEALTH ALTROOT rpool 19.9G 8.43G 11.4G - 33% 42% 1.00x ONLINE - tank 61.5G 20.0G 41.5G - 48% 32% 1.00x ONLINE - zion - - - - - - - FAULTED -
The following command destroys the pool tank and any datasets contained within:
# zpool
destroy
-f
tank
The following command exports the devices in pool tank so that they can be relocated or later imported:
# zpool
export
tank
The following command displays available pools, and then imports the pool tank for use on the system. The results from this command are similar to the following:
#zpool
import
pool: tank id: 15451357997522795478 state: ONLINE action: The pool can be imported using its name or numeric identifier. config: tank ONLINE mirror ONLINE sda ONLINE sdb ONLINE #zpool
import
tank
The following command upgrades all ZFS Storage pools to the current version of the software:
#zpool
upgrade
-a
This system is currently running ZFS version 2.
The following command creates a new pool with an available hot spare:
# zpool
create
tank
mirror sda sdb
spare
sdc
If one of the disks were to fail, the pool would be reduced to the degraded state. The failed device can be replaced using the following command:
# zpool
replace
tank
sda sdd
Once the data has been resilvered, the spare is automatically removed and is made available for use should another device fail. The hot spare can be permanently removed from the pool using the following command:
# zpool
remove
tank
sdc
The following command creates a ZFS storage pool consisting of two, two-way mirrors and mirrored log devices:
# zpool
create
pool
mirror sda sdb
mirror sdc sdd
log mirror
sde sdf
The following command adds two disks for use as cache devices to a ZFS storage pool:
# zpool
add
pool
cache
sdc sdd
Once added, the cache devices gradually fill with content from
main memory. Depending on the size of your cache devices, it could take over
an hour for them to fill. Capacity and reads can be monitored using the
iostat
subcommand as follows:
# zpool
iostat
-v
pool
5
The following commands remove the mirrored log device mirror-2 and mirrored top-level data device mirror-1.
Given this configuration:
pool: tank state: ONLINE scrub: none requested config: NAME STATE READ WRITE CKSUM tank ONLINE 0 0 0 mirror-0 ONLINE 0 0 0 sda ONLINE 0 0 0 sdb ONLINE 0 0 0 mirror-1 ONLINE 0 0 0 sdc ONLINE 0 0 0 sdd ONLINE 0 0 0 logs mirror-2 ONLINE 0 0 0 sde ONLINE 0 0 0 sdf ONLINE 0 0 0
The command to remove the mirrored log mirror-2 is:
# zpool
remove
tank
mirror-2
The command to remove the mirrored data mirror-1 is:
# zpool
remove
tank
mirror-1
The following command displays the detailed information for the pool data. This pool is comprised of a single raidz vdev where one of its devices increased its capacity by 10 GiB. In this example, the pool will not be able to utilize this extra capacity until all the devices under the raidz vdev have been expanded.
#zpool
list
-v
data NAME SIZE ALLOC FREE EXPANDSZ FRAG CAP DEDUP HEALTH ALTROOT data 23.9G 14.6G 9.30G - 48% 61% 1.00x ONLINE - raidz1 23.9G 14.6G 9.30G - 48% sda - - - - - sdb - - - 10G - sdc - - - - -
Additional columns can be added to the
zpool
status
and zpool
iostat
output with
-c
.
#zpool
status
-c
vendor,model,size NAME STATE READ WRITE CKSUM vendor model size tank ONLINE 0 0 0 mirror-0 ONLINE 0 0 0 U1 ONLINE 0 0 0 SEAGATE ST8000NM0075 7.3T U10 ONLINE 0 0 0 SEAGATE ST8000NM0075 7.3T U11 ONLINE 0 0 0 SEAGATE ST8000NM0075 7.3T U12 ONLINE 0 0 0 SEAGATE ST8000NM0075 7.3T U13 ONLINE 0 0 0 SEAGATE ST8000NM0075 7.3T U14 ONLINE 0 0 0 SEAGATE ST8000NM0075 7.3T #zpool
iostat
-vc
size capacity operations bandwidth pool alloc free read write read write size ---------- ----- ----- ----- ----- ----- ----- ---- rpool 14.6G 54.9G 4 55 250K 2.69M sda1 14.6G 54.9G 4 55 250K 2.69M 70G ---------- ----- ----- ----- ----- ----- ----- ----
zpool
to dump core on exit for the purposes
of running
::findleaks.zpool
status
and zpool
iostat
output.zpool
online
or zpool
clear
commands. This has the same effect as
passing the --power
option to those commands.zpool
looks for device nodes and files. Similar to the
-d
option in zpool
import
.zpool import
will wait for an expected device to be available.zpool
status
. The value is
not used, only the presence or absence of the variable matters.zpool
subcommands to output vdev guids by
default. This behavior is identical to the zpool
status
-g
command line
option.zpool
subcommands to follow links for vdev
names by default. This behavior is identical to the
zpool
status
-L
command line option.zpool
subcommands to output full vdev path
names by default. This behavior is identical to the
zpool
status
-P
command line option.For example, a pool that originated on illumos platform would
have a devid value in the config and
zpool
status
would fail
when listing the config. This would also be true for future Linux-based
pools.
A pool can be stripped of any devid values
on import or prevented from adding them on zpool
create
or zpool
add
by setting
ZFS_VDEV_DEVID_OPT_OUT.
zpool
status
/iostat
-c
. Normally, only unprivileged users are allowed
to run -c
.zpool
status
/iostat
-c
. This is a colon-separated list of directories
and overrides the default ~/.zpool.d and
/etc/zfs/zpool.d search paths.zpool
status
/iostat
-c
. If ZPOOL_SCRIPTS_ENABLED is
not set, it is assumed that the user is allowed to run
zpool
status
/iostat
-c
.zfs(4), zpool-features(7), zpoolconcepts(7), zpoolprops(7), zed(8), zfs(8), zpool-add(8), zpool-attach(8), zpool-checkpoint(8), zpool-clear(8), zpool-create(8), zpool-destroy(8), zpool-detach(8), zpool-events(8), zpool-export(8), zpool-get(8), zpool-history(8), zpool-import(8), zpool-initialize(8), zpool-iostat(8), zpool-labelclear(8), zpool-list(8), zpool-offline(8), zpool-online(8), zpool-reguid(8), zpool-remove(8), zpool-reopen(8), zpool-replace(8), zpool-resilver(8), zpool-scrub(8), zpool-set(8), zpool-split(8), zpool-status(8), zpool-sync(8), zpool-trim(8), zpool-upgrade(8), zpool-wait(8)
March 16, 2022 | OpenZFS |