|DMA(8)||System Manager's Manual||DMA(8)|
dmais a small Mail Transport Agent (MTA), designed for home and office use. It accepts mails from locally installed Mail User Agents (MUA) and delivers the mails either locally or to a remote destination. Remote delivery includes several features like TLS/SSL support and SMTP authentication.
The options are as follows:
-Acacts as a compatibility option for sendmail.
All other modes are are ignored.
-oiis synonymous to
-i. All other options are ignored.
dmawill parse the
Bcc:header will be removed independent of whether
-tis specified or not.
dmacan be configured with two config files:
These two files are stored per default in /etc/dma.
dmacan be configured in dma.conf.
dmawill deliver all mails to this port, regardless of whether a smarthost is set or not.
nam: dest1 dest2 ...
namwill instead be delivered to
dest2, which in turn could be entries in /etc/aliases. The special name ‘
*’ can be used to create a catch-all alias, which gets used if no other matching alias is found. Use the catch-all alias only if you don't want any local mail to be delivered.
dma's spool directory. Just stick with the default.
AUTHPATH(string, default=not set)
FINGERPRINTPin the server certificate by specifying its SHA256 fingerprint. Only makes sense if you use a smarthost.
dmais used without a smarthost, delivering remote messages directly to the outside mail exchangers; in opportunistic TLS mode, the connection will be encrypted if the remote server supports STARTTLS, but an unencrypted delivery will still be made if the negotiation fails. Only useful together with ‘SECURETRANS’ and ‘STARTTLS’.
dmadefers your mail. You have to flush your mail queue manually with the
-qoption. This option is handy if you are behind a dialup line.
dmauses to identify the host. If not set or empty, the result of gethostname(3) is used. If ‘MAILNAME’ is an absolute path to a file, the first line of this file will be used as the hostname.
-fflag and the
If ‘MASQUERADE’ does not contain a
@ sign, the string is interpreted as a host
name. For example, setting ‘MASQUERADE’ to
john@’ on host
hamlet’ will send all mails as
john@hamlet’; setting it to
percolator’ will send all mails
Sm off username
dmacan be influenced by some environment variables.
firstname.lastname@example.org. This value will be overridden when the ‘MASQUERADE’ config file setting or the
-fflag is used.
J. B. Postel, Simple Mail Transfer Protocol, RFC 821.
J. Myers, SMTP Service Extension for Authentication, RFC 2554.
P. Hoffman, SMTP Service Extension for Secure SMTP over TLS, RFC 2487.
dmautility first appeared in DragonFly 1.11.
dmawas written by Matthias Schmidt <email@example.com> and Simon Schubert <firstname.lastname@example.org>.
|February 13, 2014||x86_64|